VMware Tools Don’t Work in Ubuntu 8.10

Found these two links to information about VMware Tools not working with Ubuntu 8.10. I’ve been looking for a solution to this myself since testing with Ubuntu 8.10 Alpha 5…

From the FAQ:

Tools compile cleanly on 8.10 (Intrepid Ibex) but do not work

There are several aspects to this – soft ungrab not working, mouse clicks being displaced, vmware-user not starting (and so Unity and other dependent features don’t work).

Explanation

Soft ungrab not working and mouse clicks being displaced are known Ubuntu vmmouse bugs. An update is not yet available.

vmware-user not starting appears to be related to Intrepid’s autostart format having changed. A workaround is to go to System > Preferences > Sessions in the Ubuntu desktop menu and add /usr/bin/vmware-user as a startup command.

open-vm-tools may also work.

Disable Ubuntu System Beep!

If you’re like me, you’re probably quite annoyed with the system beep in Ubuntu. Luckily, there’s an easy fix:

To disable it temporarily:

  1. In Terminal (or the console), enter: “sudo rmmod pcspkr”
  2. You should not hear the system beep until your next system reboot.

To disable it permanently:

  1. In Terminal (or the console), enter: “sudo nano /etc/modprobe.d/blacklist”
  2. At the end of the file, enter a new line “blacklist pcspkr”
  3. Type Ctrl+O (to save the file), then Ctrl+X (to exit nano)
  4. After your next system reboot, you should no longer here the system beep.

Thanks to Turning Off The System (hardware) Beep : Linux Tutorial for the info!